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Welcome to CycloLog!
CycloLog® 2019 is a software toolbox with multiple applications in petroleum geology. The purpose of this
tutorial is to guide the user, step-by-step, through the common functions and features of CycloLog. Using
this tutorial, the new user of CycloLog should be able to:


understand the CycloLog desktop



input and display log data



perform the most important CycloLog functions



create well composite charts and correlation panels



export data from CycloLog

The tutorial is also useful, as an aide memoire, to the occasional user of the software.
Note that the tutorial is not a comprehensive guide to every function in CycloLog. That information can be
found in the Help Manual within CycloLog itself.
Note also that the tutorial is not a guide to the interpretation of CycloLog output such as INPEFA curves.
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Part 1 – Introduction to the Cyclolog desktop
1.1 Introduction to the CycloLog desktop
The CycloLog desktop uses standard Windows functionality, and looks like this:

The main components of the CycloLog desktop are:


a number of Menus (File, Edit, View …) in the main bar, at the top



a variable number of Toolbars, at the top



a number of Toolbar panes (Workspace, Information, Logging Sheet, and Memo sheet panes),
usually on the left and in the bottom left corner



a variable number of Log Data panes



a Status Bar; usually at the bottom of the Desktop

Under standard Windows functionality:


the Menu Bar, Toolbars, the Toolbar panes can be rearranged (click and drag to the required position).



the toolbars can be toggled ON or OFF (right-click over the menus/toolbars area).

PanTerra – ENRES Technical Alliance ● CycloLog Version 2019 ● Base Module ● Page 7

Note that:


The Workspace pane contains information about the contents (i.e., the wells and logs) of an opened
CycloLog project file (*.clg).





Toolbar panes can be overlaid and accessed through tabs, e.g.:


Information pane, displays information about the active, i.e. opened, Log data pane.



Logging Sheet pane, shows a record of all the actions performed in this project file.



Memo Sheet pane, allows the user to add notes to the project file.
The Properties toolbar pane contains (interactive) information about the active log (or chart) display
pane: its use is not discussed here.



When a Log Data pane is active, the Status Bar shows the same information as in the Information
pane (i.e., the depth and the value of the log(s) at the position of the cursor).

Suggestion: to maximise the window space for displaying Log Data panes, the user is advised to minimise
the number of opened Toolbars. The latter can be achieved by closing toolbars via the menu bar: View →
Toolbars.
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1.2 Using Log Data panes
The Log Data panes display any or all of the original and modified logs in the in an opened CycloLog project.


To open a Log Data pane, double-click on a log listed in the Workspace.



To close a Log Data pane, click on the Close icon, in the top right corner.



Each Log Data pane can be minimised/maximised using the other buttons in the top right corner.



Use either the Log Data pane’s scroll bar or activate the pane and use the mouse wheel to scroll up
and down a log. When more than one Log Data pane of the same well are opened, all logs will scroll.



The width of each Log Data pane can be adjusted separately; click and drag a side of the pane window
to adjust the width.



The width of all Log Data panes can be equalised using the Reposition function (or F5), which is
available (1) in the Window menu, (2) on the Standard Toolbar, or (3) using keyboard shortcut F5.



The log name and data values in the Log Data pane can be displayed on the cursor by holding down
the left-mouse button and then pressing the letter L on the key-board. Pressing on L again will toggle
the log name off leaving only the log values displayed.



Hold down left-mouse button and press the letter D on the key-board to activate the depth value. By
pressing the U-key, the opposite unit (e.g., feet) of the log depth (meters) appears on the cursor
indicator. The depth value and unit can be toggled on/off using these two key-board functions.



A grid in the log pane can toggled on/off. Activate the pane and then press the key-board letter G.
This grid functionality can also be accessed by a right-mouse click on the Log Data pane thereby
opening the context menu; select Display → Show Grid.

Further information about displaying logs can be found in the following section (Part 2) of this tutorial.
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Part 2 - Importing and displaying well log data
2.1 LAS Import


Select from the main menu: File → New, then click on the New tab.



Select LAS file and click Open.



Navigate to the file to be used and click Open.



The file will be uploaded into CycloLog.
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In the General Parameters dialog box (User Settings area), the required depth interval can be entered
(Start depth and End depth; default values are at the bottom of the well), and the Unit (in Feet or
Meters).



Keep the default Step value at 0.5 (unless you wish to change it).



Click on Next.
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In the Available Logs dialog box, select the required logs or click Select All for all logs.



Click Next.
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In the Log Order dialog box, use the Up and Down arrows to change the order of the logs, if required.
(Suggestion: place the GR log at the top of the list).



Click on Next.
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In the Log Data dialog box, the data can be viewed.



Use this box to change null values (-999.25) into zeroes (recommended), click the Change Values
button.



Click Next.
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A depth correction can be applied in the Depth Correction dialog box.



If the well is vertical and/or no correction is required, click Finish.



If the well is deviated, different types of deviation data can be entered manually or via a deviation
survey file (click Import → Plain File or LAS File and navigate to the file).



Alternatively, copy the deviation data from another file (e.g., spreadsheet) to the clipboard, and use
the Import → Clipboard option.



Click Finish.



Click the Save icon (or CTRL+S) to save and name the file (****.clg).



Note that CycloLog can only import LAS File deviation data that were exported out of Petrel (i.e., the
LAS file is a Petrel-based format).
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2.2 Managing log curves


When a well has been imported, the well and its logs will appear in the Workspace.



Re-order logs in the Workspace by clicking and dragging them up or down the list.
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2.3 Displaying log curves


Double-click on a log in the workspace to display it; right-click over a log for other options.



Open the Standard Toolbar if it is not open yet (click View → Toolbars → Standard Toolbar).



Use the Vertical Scaling option (red rectangle above) on the Standard Toolbar to change the vertical
scale; the new scale will apply to all displayed logs from the same well.



To change the vertical scale manually, place the cursor on the depth bar of the Log Data pane. Hold
down the left-mouse button on the pane and then move up or down to increase/decrease the vertical
scale.



Use the icons on the Log Toolbar (click View → Toolbars → Log bar if this toolbar is not opened yet)
to change the appearance of a log: normal/mirror display, horizontal scaling, wiggle colour, wiggle
thickness and style.



These and other options can also be accessed by right-clicking over the log pane.
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The following shows the GR curve in three different display formats: mirror-plot, cut-off toning, and colourclassified.


All three display types can be accessed from the right-click menu or, more efficient, use the Properties
toolbar.



The classified plot (rightmost image), useful for suggesting lithology, divides the range of values into
equal intervals. As can be seen in the Properties toolbar, the Colour palette style is by default discrete,
with the number of colours (intervals) set at 15, and the colours range from red (low values) to blue
(high values). These values can be changed in this toolbar.
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2.4 Overlaying log curves


To overlay logs (e.g., neutron and density), go to the main menu and select View → Log Overlay.



From the list, select the logs to be overlaid and click View.



In a pane that displays overlaid logs, change the properties of individual logs by activating the pane,
then select the log from the drop-down list on the Log Toolbar, or right-click on the pane and select
Wiggle Properties. Alternatively, the properties can be changed by using the editing options in the
properties pane.



Note that the overlaid logs cannot be saved in the workspace, however, they can be preserved in a
composite well chart (see part 4 for displaying log overlays in composite well charts).
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2.5 Importing additional wells and/or logs
A CycloLog (*.clg) file is a project file which can hold more than one well.


Multiple wells can be added using the batch load LAS functionality.



Wells can be added to the project either from another LAS file, ASCII file or from an existing .clg file.



To add a well, select File → Import and select LAS File, General ASCII or CycloLog File.



New wells and their logs will be added to the workspace.

Logs can be added to an existing well:


Go to File → Import.



Select Log from LAS File.
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Part 3 - Generating and displaying INPEFA curves
3.1 Introduction to the INPEFA curve
ENRES has developed a unique approach in well analysis and correlations, enabling more accurate and
faster well correlations: the INPEFA Log Transform (Integrated Prediction Error Filter Analysis). The INPEFA
consists of a set of algorithms that analyses the log data using linear prediction. The result of these
analyses is a curve that shows the discontinuities in the well log data. The trends and turning points of this
curve can be used for well zonation and correlation. By picking the correlation surfaces on the INPEFA
curve, this correlation approach can be considered as data-driven.

A negative trend in the INPEFA® curve is a trend to the left when going upwards along the curve (see
above). A positive trend in the INPEFA® curve is a trend to the right when going upwards along the curve.
Turning points mark the transition from a positive to a negative trend in an INPEFA® curve (‘negative
turning point’) or the other way around (‘positive turning point’). Applying a hierarchical approach to the
identification and correlation of the trends and turning points in INPEFA® curves results in a structured,
objective method for high-quality correlation of well logs.
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3.2 Generating INPEFA curves
There are different workflows in CycloLog for calculating INPEFA curves. These workflows can be entered
through:


Menu bar: Calculations.



Menu bar: Batch Operations.



Workspace worksheet: right-mouse click on a log and select Create Dynamic INPEFA log.



The key-board shortcut: Ctrl + D.

All workflows have the same mathematical formula.
As it is very advantageous to analyse shorter sections of a well to obtain a higher resolution, INPEFA curves
are dynamic. Dynamic means that it is easy to modify the interval over which INPEFA is calculated. Within
the CycloLog software, dynamic INPEFA curves are listed as D-INPEFA.

NOTE: INPEFA can be applied on any log but is often applied on the GR log as this log is considered to be
facies sensitive.

3.3 Using Dynamic-INPEFA (D-INPEFA)


Interpretation of INPEFA curves requires some experimenting with the depth interval over which
INPEFA is calculated.



This is most easily done with the Dynamic-INPEFA function.

To apply a Dynamic-INPEFA calculation on a log:


Select from the menu bar Calculations → Dynamic INPEFA.



Or use the keyboard shortcut CTRL + D.



Or right-click on the log in the workspace and select Create Dynamic INPEFA Log.
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In the Calculate Dynamic INPEFA dialog box:


Select the well.



Select the GR log (this will be the default if it is the first log in the Workspace list).



Specify the interval (note that this can easily be changed later).



If more than one D-INPEFA curve is required, check the box and specify the number of curves.



EITHER you create an X number of INPEFA duplicates on the full interval range.



OR you subdivide the INPEFA curve into a specified number of curves. The curves will be equally
subdivided within the given interval range.



Check the box Create a total log for the given range, if you wish.



The colour and name of the INPEFA curves are automatically assigned but they can be edited in the
dialog box. CycloLog uses a default colour set and name for the different INPEFA curves.



To change the default colour set, go to the menu bar: Tools → Colour Set.



Click OK.



The INPEFA curves are saved to the workspace.
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The following picture shows INPEFA curves calculated for the entire data set, and for short sub-intervals of
the data set.
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To change the interval over which a D-INPEFA curve is calculated:


Right-click over the curve.



Select Move D-INPEFA.

Horizontal bands appear at the top and base of the selected curve; when the cursor is placed on the band
it will change to a hand.


Click one of the horizontal bands and drag it up or down.



The D-INPEFA is re-calculated while dragging the bands.

The picture below shows the green D-INPEFA curve in the process of being modified:
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3.4 Overlaying multiple D-INPEFA curves in one column
When creating several D-INPEFA curves for non-overlapping or partially overlapping intervals of the same
well, it is very useful to display them in a composite well chart in a single column, thereby also saving
window space.
When the D-INPEFA curve is displayed in a composite well chart (see Part 4 for how to make composite
charts), right-mouse click over the chart and select: Log Manager  Add log, then select the D-INPEFA
curve(s) to add to the D-INPEFA column in the chart (see part 4.10 for how to add logs to a column in a
composite well chart).

3.5 Batch generation of Dynamic INPEFA curves
In CycloLog, D-INPEFA curves for more than one well can be generated. This operation is especially useful
and time-saving when many wells are in a CycloLog project file which all require INPEFA curves.
To generate a batch of Dynamic INPEFA curves:


On the main menu bar, go to Batch Operations.



Select INPEFA…, the Batch INPEFA dialog box opens:
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Select the wells and then the logs for which INPEFA calculations are to be applied. All logs that are
contained within the well selection will appear next to the Wells list in the Log names list.



Define the processing interval. This interval can be specified by using the top and bottom of a well,
depth values, breaks or reservoirs (see parts 5 and 6 for breaks and reservoirs).



Define the window size. The default size is 10m / 30ft. Values below 3m or 10ft are not recommended
for INPEFA calculation.



Define the number of (Sub)interval. This is a user defined number of parts (sub-intervals) over which
INPEFA’s will be calculated.



Click Apply. The INPEFA curves will be generated and automatically added to the workspace
worksheet. Cancel closes the Batch INPEFA dialog box.
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Part 4 - Composite well charts
4.1 The composite well chart functionality in CycloLog
This section of the CycloLog tutorial describes the composite well chart as a working chart and as a graphic
composition for reporting.
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4.2 Preparing logs for a composite well chart


Before including a log curve in a composite well chart, check that the properties of each curve are as
you like them to appear in the chart (e.g., wiggle colour and style, horizontal scale, colour fill).
Therefore, use the Properties toolbar. Note that the log properties can also be changed when the log
is included in the composite well chart.



Make overlays of logs that are to appear as overlays in the chart (e.g. NPHI/RHOB).



Make as many as required INPEFA curves that are to be included.



Note that in contrary to previous versions of CycloLog, it is not necessary to open the log panes prior
to its insertion in a composite well chart.

4.3 Creating the chart


Now go to the main menu and select Output → Composite Well Chart.



In the dialog box, check that the correct well is shown (if there is more than one in the project file).
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All logs can be selected from the list. Enter the column width. Note that this width will be applied to all
selected logs.


It is advisable to give INPEFA curves a wider column (in the example below it is set at 8).



Click Add. The dialog box now shows the curves to be included in the composite well chart, with the
width of the column assigned to each one.



If a wider column for the INPEFA curves is preferred, repeat the former action and enter a column
width of 10. Click Add.



The blue arrows allow you to move the order of the log columns as to be displayed in the composite
well chart. Note that the order can be changed in the chart later (see part 4.9).
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4.4 Viewing the composite well chart


Now click View and the composite well chart will be displayed.



Note that the composite well chart has been added to the list in the workspace.



To add e.g. NPHI for an overlay with the RHOB log, see part 4.10.



To add more short D-INPEFA curves to the D-INPEFA_GR Brown log column, see also part 4.10.
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4.5 Modifying the composite well chart
Many aspects of the composite well chart can be modified. Some of the most commonly used aspects are
described below:


Adding chart titles.



Changing the scale and modifying the scale bar.



Changing the chart interval.



Changing the order of the columns.



Adding and removing columns and logs.



Using Dynamic INPEFA curves in the composite well chart.



Changing column widths and column headers.



Several of these functions are accessed through a special context menu.



Right-click over the composite well chart to access this menu:
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4.6 Adding chart titles


By default, the composite well chart title is the name of the well.



To change or add to the title, right-click over the chart for the menu.



Select Chart Titles.



Add titles, change the fonts and colours, as required.



Click OK.
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4.7 Changing the scale and modifying the scale bar


By default, the scale of the composite well chart is the same as the logs that are in the workspace
when you started making the chart.



The scale of the composite well chart can be changed:


EITHER from the right-click menu (right-click over the chart and select Scale Vertical),



OR the vertical scale icon on the Standard Toolbar (see part 2.3),



OR by dragging the cursor up or down over the depth bar (hold down the left mouse button on the
depth bar).



To change the appearance of the scale bar, select Depth Bar Properties from the right-click menu or
go to Layout → Depth Bar Properties.



In the Depth Bar Properties dialog box, you can change the spacing of the major and minor ticks, and
the font and colour of the scale and tick marks.



Change “Settings” from Automatic to Manual to be able to make the desired changes.
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4.8 Changing the chart interval
If you do not wish to display the entire depth interval for the well:


Select Chart Interval from the right-click menu or go to the main menu bar and select Layout → Chart
Interval.



In the Select Interval dialog box, enter the desired depths in Top interval and Bottom interval for the
interval that you wish to display in the composite well chart.
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4.9 Changing the order of the columns
To change the order of the columns in a composite well chart:


Right-click over the chart for the composite well chart menu.



Select Move Column.



Over the column to be moved, hold down the left mouse button, and drag the column to its new
location.

PanTerra – ENRES Technical Alliance ● CycloLog Version 2019 ● Base Module ● Page 36

4.10 Adding and removing columns and logs


Right-click over the composite well chart to show the composite chart right-click menu.



Select Log Manager → Manage Composite Logs.



In the Composite Chart Logs dialog box, the tree structure shows the existing columns in the chart,
and the logs present in each column.

To add a column:


Click Add Column.



In the Add Column dialog box, the names of the log panes for the specific well will appear.



Select the required log, and specify the Column width.



Click OK.

To delete a column:


Click on the name of the column (e.g. DT).



Click Delete Column.

To delete a log from a column:


Click on the name of the log to select it.



Click Delete Log.

To add a log to a column:


Click on the name of the column to select it.



Click Add Log.



A list of logs is displayed from which the desired log can be selected. Note that you can select more
than one log.
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In the following picture, a log is added to an existing column in the composite well chart by selecting the
required log (e.g. the SP log) from the Add Log dialog box.

NOTE: Columns and logs can be directly added or deleted from the composite well chart.

To add a column and log directly to the composite well chart:


On the composite well chart, right-click and select Log Manager → Add Column. An empty column is
added to the chart.



Right-click on the empty column and select Log Manager → Add Log; a list with all available logs in
the well is displayed. Select the log(s). Note that you can select more than one log.

To delete a column or a log from a column:


On the composite well chart, right-click on the column you wish to delete, select Log Manager →
Delete Column or Delete Log. In the latter case, a list with the displayed logs in the column appears.
Select the log you wish to delete.
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4.11 Changing column widths and headers
Column widths and headers can be edited in the Log Columns dialog box.


Right-click over the composite well chart to open the composite chart menu.



Select Log Columns; The Column Options dialog box opens.



Select the column to be changed from the Available columns drop-down list.



Use the Column title box to type in a new title for the column.



The font and colour of the title can be changed; click on the Font and Color buttons.



The orientation of the column title can be changed to vertical: click the Vertical button.



The legend, below the column title (showing wiggle colour and minimum and maximum values) can
be toggled off if required.



The width of the column can be changed in the Width box.



Click Apply after making changes to each log.

NOTE: The width of the individual columns can be adjusted manually in a composite well chart. Therefore,
move the cursor over a column border; a double-sided arrow will appear. Hold the right mouse button
when the arrow appears and pull the column border to change its width.
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4.12 Using Dynamic INPEFA curves in the composite well chart
Dynamic INPEFA curves can be added to a composite well chart, with the advantage that they remain
interactive.
In the picture below, more D-INPEFA_GR curves have been added to the column D-INPEFA_GR Brown in
the composite well chart (see previous pages). Therefore, the right-click menu Log Manager → Add Log
has been used to add the D-INPEFA logs to the column in the composite well chart. The new column has
been re-named Short D-INPEFA_GR.

The depth interval over which each individual INPEFA is calculated can be changed:
Right-click over the column in which the short D-INPEFAs are shown.


Click on Move D-INPEFA.



From the list of D-INPEFAs in the column, select the one to be moved.



Coloured bands appear at the top and bottom of the selected D-INPEFA curve.



Click and drag these bands to the new positions.



From the right-click menu, go to Move D-INPEFA again, and deselect the log (or select another to be
changed).
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4.13 Template composite well chart
The template functionality in CycloLog enables the user to quickly and efficiently generate one or more
composite well charts using an existing composite chart as a template. The logs in a template chart are
matched to logs in the target well(s) and as soon as a match is found all layout properties of the template
chart are cloned (i.e., replicated) to the other target wells, creating new composite well charts for these
wells.
Generating composite well charts from a template can be done two ways:
1. Single composite well chart from Template
2. Batch composite well charts from Template

4.13.1 Single composite well chart from Template
This functionality is especially useful when the user only has a few wells with many different logs, or when
the user prefers to use different template layouts for different wells.


Make sure that you have made a composite well chart (see parts above), which you would like to use
as a template for another well.



Select from the main menu bar: Output → Composite Well Chart From Template.

The following dialog window opens:



In the General tab, you can define the template and target wells.
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In the Template well field, the wells are listed that contain composite well charts. In the example
above, only WELL A has composite charts. These charts are listed in the Template composite chart
field.



Select from the Template composite chart field the chart that you wish to use as template. In the
example above, Well Composite Chart has been selected.



Choose the Target well which you wish to clone from the selected template. In the Example above
WELL B has been selected.



In the Target composite chart name field, you can change the name of the composite chart for WELL
B. By default, when you select a chart from the Template composite chart field, the name of the
selected chart with the prefix Cone of will be added in the name field.



Open the Logs tab:



Here you can see which target logs CycloLog could match, by name, to the available logs in the
template well (the log name must be exact otherwise no match is made). The missing, i.e. nonmatched, logs in the target well are kept empty. If required, you can select an appropriate log from
the Target log list on the right box that best matches the Template log.
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Open the Breaks & Reservoir Sets tab:



If you have defined break and/or reservoir sets in the template and the target well, CycloLog will
automatically match the set name.



If there is no name match, you can select the appropriate set for the target chart from the Target
break set / Target reservoir set list on the right side.



Click OK.



A new composite well chart for WELL B will open, which is also automatically saved to the workspace.

4.13.2 Batch composite well chart from Template
The batch generation of composite well charts is very useful if you wish to generate composite well charts
for as many wells as possible. An existing composite well chart is used as a template to create composite
well charts for (all) other wells in the CycloLog project file. Creating multiple charts from a template is
based on cloning this template whereby the logs in the template chart are matched to logs available in the
target well. If a match is found, then all layout properties of the template are applied to the target log. See
for more details Help manual in CycloLog (section 22.4).
To create a batch of composite charts for multiple wells, the following two steps are essential:
Step 1: Log Family Manager: consists of a default list of log families, logs and/or affixes
Step 2: The Batch Composite Well Chart Template functionality
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To start with Step 1:


Select from the main menu bar: Tools → Log Family Manager.



In the Log families and the Logs field show default lists of log families and their related logs defined
internally by ENRES and can be changed any time according to your preferences. In the Log prefixes
and Log suffixes fields, a default list of these are shown and are based on CycloLog calculation
functions that generate and automatically save newly calculated logs to the workspace. If you have
changed or added differently named prefixes or suffixes to the logs in the CycloLog workspace, that
you can include them (to a certain degree) in the Log prefixes and suffixes list.

To edit the name of a log family:


In the Log families field, double click on a log family in the Name column.



A cursor will appear and you can modify the name of the log family.



If you wish to add a description to your log family, double click in the box next to the log family of
interest, in the Description column.



A cursor will appear and you can add or modify a description.



Click OK to save.
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To add a new log family:


In the Log families field, double click on the first empty row in the Name column.



A cursor will appear in the empty row and you can add the name of your new log family.



You can add a description to this new log family by double clicking in the adjacent box, in the
Description column.



A cursor will appear and you can add a description of the new log family.



Click OK to save.

To delete a log family:


Click once on a name in the Log families list; the row will be selected.



Press ‘Delete’ on your PC keyboard.



A message will appear asking whether you want to delete this Log family.



Click Yes to Delete. Note that all the logs related to the deleted Log family are deleted too.



Click on No to cancel the deletion.

To edit the name of a log:


In the Logs field, double click on a log in the Name column.



A cursor will appear and you can modify the name of the log.



Click OK to save.



Note that you also can change the order of the logs by clicking on the ‘up’ and ‘down’ buttons,
situated next to the logs list. The order is important as the batch template algorithm will consider the
highest ranked log as the most appropriate to replace a log with a different name in the target well.
For example, if you have GR in your template composite well and SGR and GRS logs in your target
well, then CycloLog will choose SGR to replace GR, because it is higher ranked than GRS in the default
log list.



Finally, you also can add a wildcard to a log. For example, you can add GR (#n) to the logs list. In this
case if you have GR in your template well, and GR (5) and GR (7) in your target then CycloLog will
match it with GR (5).

To add a new log:


Make sure to select the log family to which you want to add a new log. If you wish to add a new log
to a new log family, then first create a new log family (see above).



Go to the Logs field, and double click on the first empty row under the Name column.
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A cursor will appear in the empty row and you can add the name of your new log. Note that you can
add as many logs as you wish.



Click OK to save

To delete a log:


In the Logs field, click once on a log in the Name column.



Press ‘Delete’ on your PC keyboard; the log will be deleted directly.



If you wish to undo this deletion, click on Cancel in the Log Family Manager.



Then click Yes.

To edit a log prefix or suffix:


In the Logs prefix (or Logs suffix) field, double click on a prefix (or suffix) you wish to edit.



A cursor will appear and you can modify the name of the prefix (or suffix).



Click OK to save.

To add a new log prefix or suffix:


Make sure to activate the log family to which you want to add a new prefix (or suffix) by selecting it.



Go to the Logs prefixes (or Logs suffixes) field and double click on the first empty row in the Prefix
(or Suffix) list.



A cursor will appear in the empty row and you can add the name of your new prefix (or suffix).



Click OK to save.

To delete a log prefix or suffix:


In the Logs prefixes (or Logs suffixes) field, click once on a prefix (or suffix) you wish to delete.



Press ‘Delete’ on your PC keyboard.



The prefix (or suffix) will be deleted directly.



If you wish to undo this deletion, click on Cancel in the Log Family Manager.



Then click Yes.

The settings in the Log Family Manager are essential for a successful matching of logs and the
generation of composite well charts. Therefore, if you substantially different logs than the default
defined by ENRES, you should carefully consult the Help Manual in CycloLog.
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Continue now with Step 2:


Select from the main menu bar: Output → Batch Composite Well Charts From Template.



The Batch Composite Charts From Template dialog window opens:



Select from the Template well list the well and subsequently select from the Template composite
chart list the composite chart you wish to use as a template to generate composite charts for the
other, target, wells. Note that no composite well charts will be listed in the Template well if you
haven’t generated any beforehand.



Select the Target wells for which you want to have a composite well chart.



In the Target composite chart name you can change the name of the target well charts. We advise
you to keep the wildcard #w at the end of (or within) the text string so that the name of the target
well is added to the chart name. This is especially convenient when distinguishing composite charts
of the different wells in the workspace, or when charts are open in the main Data window.



Click on OK.



The logs and the layout of the template composite well chart will be cloned to the selected target
wells and saved to the CycloLog workspace. Always check if the logs in the charts have been cloned
properly especially if you have logs, prefixes or suffixes that are different than those in the standard
(default) Log Family Manager lists.
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If you have added a break (and/or reservoir) column to your template composite well chart then this
column and its related break (and/or reservoir) set, only will be cloned if the name of the break
(and/or reservoir) set in the target well is exactly same as in the template well.

4.14 Exporting and printing composite well charts
A composite well chart can be printed directly from CycloLog, or exported as a graphics or PDF file.
To print:


Use File → Print Setup and File → Page Setup to set the appropriate page and print parameters, then
select File → Print.

To export the composite well chart as a graphic file:


Go to Output in the menu bar, and select from the available formats: Bitmap, GIF, JPG, PNG or TIFF.

To create a PDF file, see the Help manual in CycloLog.

4.15 Deleting, duplicating and renaming composite well charts
To Delete, Duplicate or Rename a composite well chart:


Right-click over the name of the composite well chart in the workspace.



Select Delete, Duplicate, or Rename.

NOTE: A composite well chart cannot be deleted from the workspace while it is open. Therefore, close the
chart. A log that is included in one or more composite well charts can be deleted from the workspace; the
log as well as the column will then be removed from the composite well chart.
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Part 5 - Defining and managing breaks
5.1 Stratigraphic breaks in CycloLog
One of CycloLog’s principal functionality is its stratigraphic application tool. Therefore, it has powerful
features for defining and naming stratigraphically important surfaces in a well. In CycloLog, these surfaces
are referred to as breaks.


Break depths can be defined and edited.



The display characteristics of breaks can be edited.



Breaks can be organised into break-sets.



Sets of breaks can be imported and exported.

These functions are described in the paragraphs below.

5.2 Defining breaks
To define a break in CycloLog:


Display a log, composite well chart or a well correlation panel (double-click its name in the
workspace).



Place the cursor at the depth where a break is to be defined.



Hold down the CTRL key and left-click with the mouse.



The break will appear as a horizontal red line.

5.3 Moving a break
Once defined as above, a break can be moved. To do this:


Open the Break Bar (right-click over the toolbar area and select Break Bar), if it is not already open.



Select the Move Break (hand) tool.



Position the cursor over the break to be moved (cursor changes to a hand).



Click and drag the break to the new position, and release the mouse button.



If no more breaks are to be moved, de-select the Move Break tool on the Break Bar.
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5.4 Deleting a break
To delete a break:


Position the cursor over the break to be deleted (cursor changes into a flash);



Either, press the Delete key (on the key-board).



Or, single click with the left mouse button on the break and then on the Delete Break icon (X) on the
Break Bar.

5.5 Naming and editing breaks
To name a break, and to edit its properties:


Position the cursor over the break to be edited (cursor changes to a flash).



Double-click with the left mouse button.



The following dialog box opens:
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The Depth of the break is shown: it can be changed here if required.



The break can be given a name: type it into the Name box.



You can add a Comment. The existence of a Comment for Break is shown by the exclamation mark in
the depth bar of the log pane or chart (see figure below).



If the break is to be defined but not displayed, uncheck the Draw break box.



The colour, thickness and line style of the break can be defined in the Break colour, Thickness and
Line Style boxes, or you can pick a standard style from the Gallery, or use one from the Most recently
used area.



The Alignment of the break name (right, left or centred; above, over or under the break line) can also
be defined.



Click OK to save your changes.

The result of naming and editing the properties of several breaks is shown below.
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5.6 Editing break properties
The colour and line style of a break can also be edited using the Break Toolbar:


Position the cursor over the break to be modified (cursor changes to a flash), and left click once, to
select it.



Note that the Break Bar now displays the identity (break set, depth, and name) of the selected break:



On the Break Bar, use the Break color, Break style, and Break thickness drop-down lists to make your
changes.

NOTE: If more than one set of breaks has been defined (see Break Manager, below), interactive editing of
breaks is much easier with Lock Break Set enabled, as follows:


On the Break Bar, use the drop-down list to select the relevant Break Set (the “Default break set”
here is selected in the above figure), and click on the padlock icon.



Only breaks from that break set can now be selected.



Click Lock Break Set again when finished, or to select a different break set.

NOTE: The Break Bar also has icons for adding and deleting breaks, and for adding and editing break sets.
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5.7 Using the Break Manager
Defining additional sets of breaks, importing and exporting breaks, and deleting breaks and sets of breaks
are done through the Break Manager. To open the Break Manager:


Click on the Edit Breaks icon on the Standard toolbar, or



Select from the main menu Edit  Edit Breaks, or



Right-click with the cursor over one of the log panes or charts and select Break Manager.



(In case no log pane or composite well chart is open and the Break Manager is opened from the
Standard toolbar or the main menu bar, first select the required well from the drop-down list at the
top of the Break Manager dialog box).



The Break Manager will initially show one set of breaks – the Default break set. Any breaks defined
so far will belong to this Default set.
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To rename the Default break set (or any other Break Set), slowly left-click twice over the set name in
the Break Set list and type the new name (if you double-click too fast, there will be no response).
Press the enter key or click outside of the selected area.



To add another set of breaks, click Add Set and give the new set a name in the Add break set dialog
box that appears. (You can also use Duplicate to make a copy of a complete set of breaks; this useful
if you wish to subdivide a large break set.)



To delete a set of breaks, select it and click Delete Set.



You can also add, delete and edit breaks from the Break Manager.

5.8 Exporting breaks
A set of breaks can be exported in two ways; as an independent (*.brk) file, or via the Clipboard for import
into another application.
To export a break set to (for example) a spreadsheet:


Open the Break Manager.



Select the Break Set to be exported.



Click Export, then Clipboard.



Open a spreadsheet application and paste the data into it: the figure below shows the break data
from the previous figure pasted into an Excel spreadsheet.
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A break set may also be exported as a formatted file. Two formats are available in CycloLog:


Break File (*.brk), in which all of the break properties are preserved. This file can only be used as
input for CycloLog.



Tabular File (*.asc), in which only the break depth and break name are preserved, in the same (Depth,
Name) format as shown in the spreadsheet above.

To export a break set to a file:


Open the Break Manager.



Select the Break Set to be exported.



Click Export and select File.



In the Save As dialog box, name the file and select the format, Break File (*.brk) or Tabular File (*.asc),
from the Save as type drop-down list.

5.9 Importing breaks
Break sets can be imported either from a file, or from the Clipboard. (For batch import of breaks and break
sets see part on Advance Data Management in section 8.4).

To import from a file (which can be in either the Break File or Tabular File format):


Open the Break Manager.



Either, click on the Break Set to which the breaks are to be imported,



Or, create a new, empty, break set (Add Set, then give it a name).



Click Import and select File.



Navigate to the file and click Open.



The imported breaks will be added to the currently active Break Set.

To import from the Clipboard:


Make sure the break data are in the correct (Depth, Name) format, as in the spreadsheet example
illustrated above.



Select and copy the break data to be imported.



Open the Break Manager.



Either, click on the Break Set to which the breaks are to be imported,



Or, create a new, empty, break set (Add Set, then give it a name).



Click Import and select Clipboard.



The imported breaks will be added to the currently active Break Set.
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5.10 Displaying and hiding breaks
Break sets, and individual breaks, can be either displayed or hidden.


Open the Break Manager.



Use the check boxes to select which breaks and break sets are to be displayed. In the example below,
only breaks 1 and 3 from the Default break set will be displayed.

Alternatively, to hide an individual break, you can edit that break (double-click on it in the Log data pane
or composite chart to open the Edit Break manager) and uncheck the Draw Break box.
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5.11 Displaying breaks in composite well charts
The basic construction of composite well charts was described in Part 4 of this tutorial. We now describe
the steps needed to add break columns to a composite well chart, containing the stratigraphic breaks.


Having made a composite well chart, make sure that Show Breaks is enabled in the right-click menu
(right-click anywhere over the composite chart, either in a separate pane or in the composite well
chart or correlation panel).
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To create a break column in a composite well chart:


Select Break Columns from the right-click menu (right-click anywhere over the composite chart) to
open the Break Column dialog box.



The input fields will be empty but after clicking on Add the dialog box looks like this:



On the Break sets list, check the break set(s) to appear in this column.



Name the break column. The Column title (the header for the column) is automatically named after
the break column but it can be re-named.



The default values for the header font, colour, text direction and width can all be changed if required,
as can the font and colour for the break labels.



Under Drawing Width, you can specify the horizontal extent of the break lines; also, whether or not
these breaks are to appear in other break columns.



Click Apply, then go back to Add if you need to add another column.
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The result of defining a break column for the Well A composite chart is shown below:
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Part 6 - Defining and managing reservoirs
6.1 Stratigraphic intervals in CycloLog
One of CycloLog’s principal functionality is its stratigraphic application tool. Therefore, it has powerful
features for defining and naming stratigraphically important surfaces in a well. In CycloLog, these surfaces
are referred to as reservoirs.


Reservoir depth intervals can be defined and edited.



The display characteristics of reservoirs can be edited.



Reservoirs can be organized into reservoir-sets.



Sets of reservoirs can be imported and exported.

These functions are described in the paragraphs below.
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6.2 Defining reservoirs
To define a reservoir in CycloLog:


Display a log, composite well chart or well correlation panel (double-click its name in the workspace).



Place the cursor at the depth where a reservoir boundary is to be defined.



Hold down the left-mouse button and the SHIFT key and drag to the other reservoir boundary with
the mouse.



The reservoir will appear as a yellow interval bounded by two horizontal red lines.
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6.3 Moving a reservoir
Once defined as above, a reservoir may be moved. To do this:


Open the Reservoir Bar (right-click over the toolbar area and select Reservoir Bar), if it is not already
open:



Select the Move Reservoir (hand) tool.



Position the cursor over the reservoir boundary to be moved (the cursor changes to a hand).



Click and drag the boundary to the new position, and release the mouse button.



If no more reservoir boundaries are to be moved, deselect the Move Reservoir tool on the Reservoir
Bar.

6.4 Deleting a reservoir
To delete a reservoir:


Position the cursor over the reservoir to be deleted;



Single click with the left mouse button on the reservoir and then on the Delete Reservoir icon (X) on
the Reservoir Bar.
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6.5 Naming and editing reservoirs
To name a reservoir, and to edit its properties:


Position the cursor over the reservoir to be edited.



Double-click with the left mouse button.



The following Edit Reservoir dialog box opens:



The Top and Bottom depth of the reservoir interval is shown: it can be changed if required.



The reservoir can be given a name: type it into the Name box.



You also can add a Comment.



The Name properties allows display and alignment of the reservoir name (left, centered, or right; top,
middle or bottom of the reservoir interval).



The colour, thickness and line style of the reservoir boundaries can be defined by checking the boxes
for the upper or lower line, and change the Color, Thickness and Line Style, or you can pick a standard
style from the Gallery, or use one from the Most recently used area.



Click OK to save your changes.
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6.6 Editing reservoir properties
The color and line style of a reservoir boundary can also be edited using the Reservoir Toolbar:


Position the cursor over the reservoir to be modified and left click once, to select it.



Note that the Reservoir Bar should display the identity (break set, depth, and name) of the selected
reservoir.



On the Reservoir Bar, use the Reservoir top line color, Reservoir top line thickness, and Reservoir
top line style drop-down lists to make your changes to the top reservoir boundary. In the same way,
a reservoir bottom boundary can be edited.

If more than one set of reservoirs has been defined (see Reservoir Manager, below), editing of reservoirs
is much easier with Lock Reservoir Set enabled, as follows:


On the Reservoir Bar, use the drop-down list to select the relevant Reservoir Set (the “Default
reservoir set” set is selected in the above figure), and click on the padlock icon.



Only reservoirs from that reservoir set can now be selected.



Click Lock Reservoir Set again when finished, or to select a different reservoir set.

NOTE: The Reservoir Bar also has icons for adding and deleting reservoirs, and for adding and editing
reservoir sets.
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6.7 Using the Reservoir Manager
Defining additional sets of reservoirs, importing and exporting reservoirs, and deleting reservoirs and sets
of reservoirs are done through the Reservoir Manager. To open the Reservoir Manager, click on the Edit
Reservoirs icon on the Standard Toolbar or main menu bar (Edit  Edit Reservoirs), or select Reservoir
Manager by right-clicking with the cursor over one of the log panes or charts.



(In case no Composite Chart is open and the Reservoir Manager is opened from the Standard toolbar
or the main menu bar, first select the required well from the drop-down list at the top of the Reservoir
Manager dialog box)



The Reservoir Manager will initially show one set of reservoirs – the Default reservoir set. Any
reservoirs defined so far will belong to this default set.



To rename the Default reservoir set (or any other reservoir set), slowly left-click twice over it in the
Reservoir set list and type the new name (if you double-click too fast, there will be no response). Press
the enter key or click outside of the selected area.
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To add another set of reservoirs, click Add Set and give the new set a name in the Add Reservoir Set
dialog box that appears. (You can also use Duplicate to make a copy of a complete set of reservoirs;
useful if you wish to subdivide a large reservoir set.)



To delete a set of reservoirs, select it and click Delete Set.



You can also add, delete and edit reservoirs from the Reservoir Manager.

6.8 Exporting reservoirs
A set of reservoirs can be exported in two ways; as an ASCII file, or via the Clipboard for import into another
application.
To export a reservoir set to (for example) a spreadsheet:


Open the Reservoir Manager.



Select the Reservoir set to be exported.



Click Export, then Clipboard.



Open the spreadsheet application and Paste the data into it: the figure below shows reservoir data
pasted into an Excel spreadsheet.
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6.9 Importing reservoirs
Reservoir sets can be imported either from a file, or via the Clipboard. (For batch import of reservoirs and
reservoir sets see part on Advance Data Management in section 8.4).
To import from a file:


Open the Reservoir Manager.



Either, click on the Reservoir Set to which the reservoirs are to be imported;



Or, create a new, empty, reservoir set (Add Set, then give it a name).



Click Import and select File.



Navigate to the file and click Open.



The imported reservoirs will be added to the currently active Reservoir Set.

To import via the Clipboard:


Make sure the reservoir data are in the correct (Top depth, Bottom depth, Name) format, as in the
spreadsheet example illustrated above.



Select and copy the reservoir data to be imported.



Open the Reservoir Manager.



Either, click on the Reservoir Set to which the reservoirs are to be imported;



Or, create a new, empty, reservoir set (Add Set, then give it a name).



Click Import and select Clipboard.



The imported reservoirs will be added to the currently active Reservoir Set.
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6.10 Displaying and hiding reservoirs
Reservoir sets, and individual reservoirs, can be either displayed or hidden.


Open the Reservoir Manager.



Use the check boxes to select which reservoirs and reservoir sets are to be displayed. In the example
below, the Default reservoir set is being displayed, and within this set only the Middle Reservoir.
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6.11 Displaying reservoirs in composite well charts
The basic construction of composite well charts was described in part 4 of this tutorial. We now describe
the steps needed to add columns to a well composite chart, showing the reservoirs.


Having made a composite well chart, check that Show Reservoirs is enabled in the right-click menu
(right-click anywhere over the composite chart, either in a separate pane or in the composite well
chart or correlation panel).

PanTerra – ENRES Technical Alliance ● CycloLog Version 2019 ● Base Module ● Page 69

To create a reservoir column in a composite well chart:


Select Reservoir Columns from the right-click menu (right-click anywhere over the active composite
well chart) to open the Reservoir Column dialog box.



The input fields will be empty but after clicking on Add the dialog box looks like this:



On the Reservoir sets list, check the reservoir set(s) to appear in this column;



Name the reservoir column. The Column title (the header for the column) is automatically named
after the reservoir column but it can be re-named.



The default values for the header font, colour, direction and width can all be changed if required, as
can the font and colour for the reservoir labels.



Under Drawing Width, you can specify the horizontal extent of the reservoir lines; also, whether or
not these reservoirs are to appear in other reservoir or break columns.



Click Apply, then go back to Add if you need to add another column.
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The result of defining a reservoir column for the Well A composite chart is shown below:
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Part 7 - Adding special logs
7.1 Additional log types in CycloLog
CycloLog has the possibility to import log data types that are different from the regular, wireline, logs.
These log types are defined in the CycloLog code base as special logs and their related functions are
more restricted than those for the regular logs.
This section of the tutorial shows you how to add and display the following kinds of log data to a CycloLog
project:


Casing logs



Interval logs (for e.g., lithostratigraphy, chronostratigraphy, biozones)



Biostratigraphic logs (for biostratigraphic data)



Comment logs

7.2 Adding a Casing Log
A casing log shows the depth position of casing shoe data. In the example below, the following casing shoe
depths are to be loaded into a new Casing Log for the Well A:
Depth(m)
3250.00
3375.65
3462.60
3716.90

Diameter
30”
20”
13 3/8”
9 5/8”

The easiest way to load casing shoe data is via the clipboard.


Type the data in the format shown in a spreadsheet or text editor.



Copy the data to the Clipboard.



Right click over Depth domain under the well’s name in the workspace.

Note: You can add a casing log from the main menu bar: File → Add Log → Casing Log.
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In the menu that opens, select Add Log.



In the next menu, select Casing Log.



The Casing Log is created, and added to the workspace list.

To add the data to the new Casing Log:


Open the Casing Log (double-click on its name in the workspace);



Right-click on the casing log pane and select the Log Data menu item.



This opens the Casing shoes dialog:

If you have copied the data to the clipboard:


Click the Import button, and select Clipboard.



Click Close.
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If you have copied the data to a file:


Click the Import button, and select File.



Click Close.

Otherwise, you can add the data line by line:


Click the Add button, and type in the Depth and Description for each item.



Click Close.

The Casing Log now looks as follows:

Note: The Casing Log can be added to a composite well chart (see part 4 of this tutorial).
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7.3 Adding an Interval Log
Interval Logs in CycloLog are a flexible way of adding any kind of information that is expressed in depth
intervals. Typical examples are lithostratigraphy (formations, members, etc.), chronostratigraphic age
(periods, epochs, stages, etc.), and biozones. Interval logs could also be used to show cored intervals.
To create an Interval log:


In the CycloLog workspace, right click over the well’s Depth Domain.



In the menu that opens, select Add Log.



In the next menu, select Interval Log.



The Interval Log is created, and added to the Workspace list;



To rename the new log, right-click over its name in the workspace list, and select Rename from the
menu; type in the new name (e.g. Lithostratigraphy).

Note: You can also add an interval log from the main menu bar: File → Add Log → Interval Log.
In the example illustrated, the following formations are to be added to an interval log:
Top
3518.00
3315.00
3518.00

Base
3585.00
3518.00
3585.00

Name
Formation C
Formation B
Formation A
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To add data to the new interval log:


Open the Interval Log (double-click on its name in the workspace);



Right-click over the Interval Log pane, and select Log Data.



The Interval Log Data dialog box opens:



Click the Add button (at the top) to create a column of data.



The name ‘Column’ appears in the Column properties field; to change it, click in the Name box and
delete the name ‘Column’. Type in your preferred name (e.g., ‘Formations’). This name will appear at
the top of the column in a composite well chart.



The Font and Font Color buttons allow you to change the appearance of the column header; the Text
direction of the header can be toggled between Horizontal and Vertical.



The width of the column is 1 cm by default, but can be changed: type in your preferred width (in cm).



The fill of the column can also be defined: click the Background down-arrow and select the colour
and/or pattern to be used as fill.

You can add data one line at a time, or you can import data from the clipboard or from a file.
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To add a line of data:


Click the Add button (under Interval data).



The Define Interval dialog box opens:



Type in the name of the interval, and its top and bottom depths.



The Font and Font Color (default = Arial 8, black) can be changed, as can the Text direction (horizontal
or vertical).



The style of the lines at the upper and lower limits of the interval is solid by default, but can be
changed; there is also an option for either line to be wavy (for an unconformity).



If Show top/bottom depth is checked, the depth will be shown at the limits of each interval.



The Background of each interval can be individually defined: click on the down-arrow in the
Background box and select the colour and/or pattern.



If the interval is too narrow to contain the text, you can check Expand interval (and/or choose a
smaller font size for the text).



Click OK, then click Add again, to define the next interval.



Click Apply to save your changes, and Close when you have finished.
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To add data from the Clipboard:


Copy your data (in the format shown above – Top depth, Bottom depth, Name – for each interval).



Click the Import button on the Interval Log Data dialog box.



Select Clipboard, and the data will be added to the interval log.



You can now Edit each item (e.g., to add a different background).

To import data:


Note that the file format must consists of tabulated data (*.asc) with the following three columns: 1)
a top depth, 2) a bottom depth, and, 3) a description column.



Click the Import button on the Interval Log Data dialog box.



Select Plain File, and the data will be added to the interval log.



Select Edit to assign color and other Style properties manually.

NOTE: To export or edit several Interval Logs in one go, see the section on the Set Manager in part 8 of this
tutorial.
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7.4 Adding a Biostratigraphic Log
Biozones are best expressed in CycloLog as Interval Logs: see the instructions given in the previous section.
Biostratigraphic data in the form of First Appearances, Acmes, and Last Appearances can be added to a
Biostratigraphic Log, as follows:


Right click over Depth domain under the well’s name in the workspace.



Select Add Log, then Biostrat Log.

Note: You can also add a biostrat log from the main menu bar: File → Add Log → Biostrat Log.


The new log appears in the workspace list: open the log by double-clicking over its name.



To add data to the new log, right-click over the opened Biostrat Log.



Select Log Data to open the Biostrat Data dialog box (shown here with some data already entered):
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To add a single line of data:


Click the Add button to open the following dialog box:



Enter the Depth, and the Description text to appear on the log.



Under Type, select the type of biostratigraphic event from the drop down list.



Note that the Font and Font Color can be changed from the default; changing the font size may be
useful if the events are very crowded on the log.



Click OK.
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To add several lines of data from the clipboard or from a file, suppose that the following events are to be
added:
Depth
3630.25
3700.00
3712.48



Type
Species C
Species D
Species D

Format the data as above in a text editor or spreadsheet: note that the type of event cannot be
specified until the data have been entered.



Copy the data (without the column headings) to the clipboard.



On the Biostrat Data dialog box (see above), select Import, and then Clipboard (or File if you have
created a file with the tabulated data).



The new data are added to the Biostrat Log; all are assumed to be Appearances: Edit those lines of
data for which the event type is to be different.



The Biostratigraphic Log now appears like this:

Note the different arrow symbols for First Appearance, Appearance, ACME, and Last Appearance.
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7.5 Adding a Comment Log
A Comment Log can be created when you need to be able to show text comments at specific depths in
the well. To add a Comment Log:


Right click over Depth domain under the well’s name in the workspace.



Select Add Log, then Comment Log.

Note: You can also add a Comment log from the main menu bar: File → Add Log → Comment Log.


The new log appears in the workspace list: open the log by double-clicking over its name.



To add data to the new log, right-click over the open Comment Log.



Select Log Data to open the Comments dialog box (shown here with some data already entered):
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To add a comment:


Click the Add button.



Your comment can apply to a single depth, or to a depth interval: select Depth or Interval.



In case there are several comments close together, you can show a comment at a different depth:
put the depth at which it is to appear in the Show at depth box.



Select a fill colour from the Background box.



Type your comment into the Comment box, and change the Font and Font Color if you wish. (If there
are many comments, reduce the font size.)



Click OK.
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The following shows the appearance of the Comment Log: if there is overlap between Comments,
you can (1) increase the vertical scale; (2) reduce the font size of individual Comments, or (3) change
the Show at Depth for one or more comments.

7.6 Other special log types
Other types of log are also available in the Depth domain right-click menu (See CycloLog Help for details):


Tadpole logs



Core plug data logs



Image logs



Bar Log
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7.7 Adding special logs to a composite well chart
All types of special logs can be added to a composite well chart. To do this:


Open a composite chart (or create a new one – see CycloLog tutorial, part 4).



Right-click with the cursor over the composite chart.



Select Log manager, then Manager Composite logs.



In the Composite Chart Logs dialog, click Add Column.



Select the log that you wish to add, specify the width of the column it is to appear in, and click OK.
Note that you can add only one column at a time.

See part 4 of this tutorial for advice on modifying the appearance of the new column, or changing its
position in the chart.
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Part 8 - Advanced data management
8.1 Advanced data management functions in CycloLog
This section of the Tutorial describes the basic use of several features that have been designed to speed
up the management of data in CycloLog, such that larger datasets can be handled more efficiently.

8.2 Log template manager
Prior to the batch import of LAS files, the basic display properties for each log can be set using the Log
Template Manager. The Log Template Manager offers standard settings for each type of recognized log;
it also establishes the order in which the logs will appear under each well in the Workspace after batch
import. Default settings are available, but all of these settings can be changed to the users preferred
values. Also, special log types can be added to the default scheme.

To use the Log Template Manager:


Prior to (batch) importing of LAS files, select from the main menu bar: Tools → Log Template
Manager.



The illustrated example shows the Log Template Manager open, with the information for the GR log
selected.
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The information for the display of each log includes:


Minimum and Maximum values for the horizontal scale.



The Color, Thickness and line Style of the log curve.



The Display mode of the horizontal scale: whether linear (‘normal’) or logarithmic.

To change the Minimum and Maximum scale values:


Click in the relevant box and type the required value.

To change the line Color, Thickness or Style:


Select the log by clicking on the box at the left end of the line – this reveals drop-down lists.



Select the colours or values you want from the drop-down lists.

To change between linear and logarithmic in the Display mode:


Select the log by clicking on the box at the left end of the line – this reveals drop-down lists.



Select Normal or Logarithmic from the drop-down list.
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To add another type of log to the Log Template Manager:


Click the Add button once for each new log.



Scroll to the bottom of the list where the log is added.



The new log(s) will be listed with the name ‘Log’:

Change ‘Log’ to the correct log name.


Edit the other values as described above.

To delete a log from the Log Template Manager:


Select the log by clicking on it on the left (it must be highlighted in blue).



Click the Delete button.

To apply the settings in the Log Template Manager:


Click the Close button.



Now you can batch import files using the predefined log settings. To batch import log files, follow the
steps as described below.
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8.3 Batch import of logs
Importing logs, and standardizing their horizontal scales and other features of their display, can take up a
significant amount of time. CycloLog offers a means of importing logs contained within multiple wells in
batches, giving the same type of logs the same properties.

To import a batch of logs:


For all wells to be entered, assemble their LAS files into one folder.



From the File menu, click on New (or use the shortcut CTRL+N).



The following dialog window opens:



Select the New tab.



Select LAS File (Batch) and click Open.



Navigate to the folder with the required LAS files.



Select the LAS files for all the wells to be imported.



Click Open.
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CycloLog loads the wells (this may take some time – see the Progress bars at the left of the following
display):



This interactive display shows which wells have been loaded and allows you to add more wells (click
Add Files) and to change some key parameters.



LAS files need to have the same depth units when loaded into CycloLog. To unify the Depth Units,
click on All Meters or All Feet to select the required unit.



To change the depth step for a well, enter the required value in the Step column.



The default setting for NULL values is to change all Null values to zero. To leave Null values unchanged,
uncheck the box; to change all Null values to a different value, enter the required value in the Change
NULL column.



If the well is deviated and a deviation survey is available:


check the box in the Deviation data column, then



click in the space to the right of the check box



click on the button showing three dots to open the Deviation Survey dialog box (see part 2 of this
tutorial).
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To change the selection of log curves and to arrange their order, click on the curve list, then click
again on the button showing three dots to open the Log List:



Check the logs that you wish to import.



Use the Up and Down arrow buttons to move a selected log up or down the list until they are in the
required order.



Click OK.



Repeat the above steps for the remaining wells in the batch.



Click OK when you have made all necessary changes.



CycloLog creates a new project file, with all wells and all their logs shown in the workspace.



Save the new project as a *.clg file.
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8.4 Batch import of breaks and reservoirs
Batch importing can also be done for both breaks and reservoirs. Batch importing of breaks is illustrated
here; batch importing of reservoirs is similar as described for breaks.
The breaks to be imported must first be saved in a tabulated text file. The name of the well must exactly
match its name in the CycloLog project file.

To import this information:


Go to the File menu and select Import.



Select Batch Import Breaks.



Navigate to the file containing the tabulated breaks, and click Open.
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The data from the text file appears in the Skip Lines dialog:


Set the Number of lines to skip equal to the number of lines of header data in your file (1 line in the
example shown).



Click OK;
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The Batch Import Breaks dialog box opens:



The default name in the Break set name field will be Batch Imported; change this if you wish to (e.g.,
into Default break set, as in the example).



In Well name column, select the column that contains the well name(s).



In Depth column, select the column that contains the break depths.



To include the names of the breaks, check the Include break name box, and, in Break name column
field, select the column that contains the break names.



If necessary (for example, you have for some wells also data in the TVD domain) indicate for each well
the domain into which the breaks need to be imported.



Click Import.



The breaks are imported; Close the Batch Import Breaks dialog.



Open the Break Manager (Edit Breaks, from the Edit menu) if you wish to edit the newly imported
breaks (see CycloLog tutorial, Part 5).
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8.5 Break template manager
CycloLog users may like to develop their own preferred line styles for showing different kinds of breaks.
The Break Template Manager allows the user to set up and name preferred break line styles. These styles
can then be selected with a single click when editing a break.

To open and use the Break Template Manager:


Go to the main menu bar and select Tools → Break Template Manager (you also can access this
manager through the Break Manager by double-clicking on a break. The Edit Break dialog allows
access to the break template manager through the Templates button).

The Break Template Manager already shows a number of predefined line styles (Example 1, Example 2,
etc.). You can modify or delete any of these; you can also add new styles.

To rename any of these line styles:


Select the style to be renamed in the box on the right (the figure shows ‘Sample’ selected).



Type the new name into the Style name box at the top left of the dialog box.
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To add a new line style:


Click the yellow New (Insert) button at the top right of the dialog box.



A new style is added to the list on the right, initially named ‘Sample’: by default, it is a 1-pixel thick
solid black line.



To rename the new style, type a name in the Style name box.



Define the Colour, Thickness and Style (solid, dashed, etc.) from the drop-down lists.



Select the Alignment of the break name, i.e., whether it is to appear at the Left, Center, or Right of
the break (Horizontal alignment), and whether the name should appear on the Top, Middle, or
Bottom of the line (Vertical alignment).

To change the order of appearance of the styles:


Select a style and use the Up and Down arrow icons to move it up or down the list.



Repeat until the styles are in your preferred order.

To delete any of these line styles:


Select the style to be deleted in the box on the right (the figure shows ‘Sample’ selected).



Click the Delete icon (X) at the top right of the dialog box.

When you have finished:


Click OK to save your changes.
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8.6 Reservoir template manager
Users may develop their own preferred styles for showing different kinds of reservoirs; the Reservoir
Template Manager allows the user to set up and name preferred reservoir styles. These styles can then
be selected with a single click when editing a reservoir.

To open and use the Reservoir Template Manager:


Go to the main menu bar and select Tools → Reservoir Template Manager (you also can access this
manager through the Reservoir Manager by double-clicking on a reservoir. The Edit Reservoir dialog
allows access to the reservoir template manager through the Templates button).

The Reservoir Template Manager initially shows only one predefined style, with the default name
‘Sample’. This style can be changed, and/or renamed, and others can be added.
To modify an existing reservoir style:


Select ‘Sample’ on the right.



Make changes as described for a new style (below).



Click OK.
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To add a new reservoir style:


Click the yellow New (Insert) button at the top right of the dialog box.



A new style is added to the list on the right, initially named ‘Sample’. By default, it has yellow fill and
no upper or lower lines.



To rename the new style, type a name in the Style name box.



Under Name properties, select the Font, Font color, the Horizontal and Vertical location, and
Orientation of the reservoir name from the drop-down lists.



If you want the reservoir to be bounded by upper and lower lines, check the Upper line reservoir
and/or Lower line reservoir boxes, and specify the properties of the lines (note that upper and lower
lines can have different properties).



Click OK to save your changes.

To change the order of appearance of the styles:


Select a style and use the Up and Down arrow icons to move it up or down the list.



Repeat until the styles are in your preferred order.

To delete a reservoir style:


Select the style to be deleted in the box on the right (the figure shows Sample selected);



Click the Delete icon (X) at the top right of the dialog box.

When you have finished making changes:


Click OK to keep your changes.
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8.7 Log Set Manager
The Set Manager is a powerful tool to change many properties simultaneously for multiple wells.

To open the Set Manager:


Go to the main menu and select Edit → Set Manager, or select Set Manager from the right-click menu
on a composite well chart.



In the Set Manager dialog window, select Log Sets from the left-hand column.



The right-hand column will display all the log types found in all the wells in the project.

To define properties of all logs of a particular type:


Select the required type of log (in the example below the ‘GR’ log has been selected).



Check the boxes for the log display properties that you wish to define.



Enter the required properties, or select them from the drop-down lists.



Click Apply.
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Click the name of the next log, and repeat until you have made all your changes, always clicking Apply
before you move on to the next log.



Click Close.



All logs of the types defined will have their properties set to the specified values.

Note: Properties of special logs, such as the Bar, Interval, Plug, and Tadpole logs, can also be edited.

8.8 Using the Break Set Manager (and Reservoir Set Manager)
The Break and Reservoir Set Managers allow you to make changes to multiple breaks/reservoirs
simultaneously. The use of the Break Set Manager is described here: using the Reservoir Set Manager is
analogous.


In the Set Manager dialog window, select Break sets from the left-hand column.



The Set Manager displays a list of all break sets and breaks present in all the wells in the project:
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You can reduce or increase the number of columns displayed:


Right-click with the mouse on the window.



From the context menu; select the Columns you want to have displayed.

Note: The list of breaks is initially sorted by Well name.

To change the sorting order:


Click on the name of the column by which to sort the data, and drag it to the grey box at the top (see
below).
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You can do this more than once: the example below shows breaks sorted by break set, and then by
break.



To remove a sorting parameter, drag its name away from the grey area.



Note that you also can change the order of the columns by dragging a column to the left or right.
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To make changes to the break properties:


In the Set Manager dialog box, sort the breaks into a convenient order.



Select the breaks whose properties you wish to edit.
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Right-click with mouse button to open the context menu, and select Edit Breaks.



The Edit Multiple Breaks dialog box opens.



Check the boxes for the properties that you wish to change/define for all of the selected breaks.



For each selected property, enter the required value, or select from the drop-down lists.



To use the predefined styles in the Gallery, first check the Gallery box, then click on the style.



Click OK to apply the properties to all selected breaks.
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To export breaks:


In the Set Manager, sort the break sets (and wells) that you wish to export (by dragging columns to
the grey area, see above).



Select the breaks and then right-click to open the context menu (to select multiple breaks, hold down
Shift).



Select Export Breaks; you can either save the breaks as a tabulated data File or save them to the
Clipboard.

Note: Selected breaks can also be deleted using the Delete Breaks option in the context menu.
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Part 9 - Correlation Panel
9.1 Correlation Panels in CycloLog
Correlation panels in CycloLog comprise a selection of composite well charts. The correlation lines defined
in each composite chart can be connected automatically. Comprehensive editing functions for the
correlation panel allows to add more lines, depict unconformities, and add textual and graphical
information, thereby finalising the layout of the panel, which can be printed or exported as required.

This section of the tutorial gives basic instructions on how to construct a simple correlation panel.

9.2 Preliminaries
To make a correlation panel, please note the following important conditions:


All wells that are to appear in a correlation panel must be in the same CycloLog project. (See tutorial
part 2 on how to import additional wells into a CycloLog project file.)



All wells that are to appear in a correlation panel must have composite well charts generated first.



If you wish CycloLog to automatically draw correlation lines between wells, the equivalent breaks
must be in break sets that have exactly the same name in each well. Also the breaks must have
identical names.
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9.3 Planning a correlation panel
A correlation panel is a collection of composite well charts linked by correlation lines. You can use
composite charts that you have already created for another purpose, or you can create them especially
for your correlation panel. Although you can change the layout later (including the layout of each
composite chart) it is best to start by considering the overall layout of the panel:


How many wells, and in what order from left to right?



How many columns are essential in each composite chart (it is good practice to keep the width of
each chart to the minimum)?



What vertical scale would be best? (It does not have to be the same in all wells.)



Can you estimate the overall paper size that will be needed?

9.4 Customizing composite charts for use in a correlation panel
If you wish to use a modified (e.g., reduced) version of an existing composite well chart:


Make a duplicate of the chart (right-click over its name in the workspace, and select Duplicate).



The name of the duplicated chart will have the suffix ‘- Copy’.



Rename the chart if you wish (right-click over its name in the workspace, and select Rename).



Open the duplicated chart: you may now wish to make some changes to it (see also CycloLog tutorial,
part 4).
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9.5 Creating a Correlation Panel
To create a new correlation panel:


Go to the Output menu, and select Correlation Panel.



The Paper Size dialog window opens:



Specify the Paper Size (this can be changed later: it is better to start with it too large rather than too
small).



You can use one of the Predefined sizes (A0 to A4), or you can select Custom and specify the size (in
centimeters) yourself.



Specify the Margins (this can also be changed later).



Specify the Orientation (Portrait or Landscape).



Click OK.



A blank Correlation Panel is created and opens in CycloLog’s main window. It also appears in the tree
structure in the workspace, where it can be renamed.
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To add composite well charts to the panel:


EITHER go to the main menu bar and select Layout → Insert → Composite Chart.



OR click the Composite Chart icon on the Drawing toolbar:



Move the cursor over the correlation panel pane: it changes to a cross.



Move the cross to where you would like the top left corner of the first composite chart to appear (its
position can be changed later).



Click the left mouse button.



In the dialog box that opens, navigate to the wells you want, then select the required charts from the
list of Available composite charts.



Click OK.



The chosen composite charts appear on the correlation panel.



The chart will now appear something like this:

You can adjust the position of the individual charts, as follows:


Click on a chart to select it.



You can use the arrow keys to move the chart, or you can hold down the left mouse key, and drag
the chart to its new position.
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9.6 To edit composite charts from the well correlation panel
Modifications to a composite well chart within a correlation panel can be made in the same way as for a
separate composite well chart (see Cyclolog tutorial, part 4). Use the right-click menu to access the editing
options:

From these editing options, the following are only accessible from the correlation panel: Delete Chart,
Connect Breaks and Connect Reservoirs.
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9.7 To connect breaks/reservoirs automatically
To connect breaks or reservoirs in adjacent wells, correlation lines can be drawn automatically. The
workflow for connecting reservoirs is analogous to that of breaks. Therefore, only the workflow for breaks
is shown here. In order to be connected, the names of the break sets and their respective breaks must be
the same for all wells.
To check which breaks will be connected by CycloLog:


Right-click on a composite well chart, select Connect Breaks, and select a break set.



Breaks recognised by CycloLog as being the same are connected.



You can connect more than one break sets as long as they have the same name in all wells.

Use this display to check that the breaks have been connected as expected. If not, check the following:


Breaks are given exactly the same name in each well.



Breaks are in a break set having exactly the same name in each well.



Breaks are checked in the Break Manager (right-click on a composite chart and select Break Manager)

PanTerra – ENRES Technical Alliance ● CycloLog Version 2019 ● Base Module ● Page 111

9.8 Adding correlation lines manually
Correlation lines can also be drawn manually to connect breaks or reservoirs in adjacent wells. The
workflow for manually connecting reservoirs is analogous to that of breaks. Therefore, only the workflow
for connecting breaks manually is shown here.
Breaks in one well that have no equivalent in an adjacent well will not be connected automatically by
CycloLog. However, you may wish to add more correlation lines, to make your interpretation clearer.

How to add a correlation line manually:


On the Drawing toolbar, click the Correlation Line icon:



(Alternatively, select from the main menu bar Layout → Insert → Correlation Line.)



When the cursor is moved close to the edge of one of the composite charts, and close to the position
of a break, the cursor changes to a cross and a flash:



Position the cursor at one end of the line you wish to draw (the position need not be exact).



Hold down the left mouse button, and drag the cursor to the break on the adjacent well that you wish
to connect (cursor changes to cross-and-flash again).



Release the mouse button; CycloLog completes the line.



Once the action is completed, switch off the ‘correlation line’ functionality, by clicking on the ‘select
arrow’ in the drawing toolbar, or ‘somewhere in the correlation panel’.
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You can also use the same operations to connect a break in one well to anywhere along a correlation line:

To delete a correlation line:


Click on the correlation line to be deleted.



Small black squares appear at the ends of the selected line (see above).



Click the keyboard Delete key.

9.9 Changing the hang level
CycloLog can change the vertical alignment (the ‘hang level’) of the wells in a correlation panel. The wells
can be ‘hung’ by depth, by break, or (if reservoirs have been defined) by reservoir.

To set, or change, a hang level:


From the main menu bar, select Layout → Actions → Hang Level.



From the dialog box, select Use Depth, Use break, or Use reservoir.



If a break or a reservoir is used, the dialog box will offer a drop-down list of all the breaks (or
reservoirs) defined in this project. Select the break (or reservoir) to be used as hang level, and click
OK.



The vertical alignment of the wells changes such that the chosen hang level (depth, break, or
reservoir) is horizontal.
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9.10 Adding a title box or a graphic
Two kinds of text boxes are available: a simple Text Box, and a Rich Text Box. A simple Text Box can display
text without or with less formatting than a Rich Text Box. Both textboxes can be used to create a title box,
or to add any other kind of textual information in a correlation panel.

To add a Text Box to a correlation panel:


Click on the Text box icon on the Drawing Toolbar:



Alternatively, go to the main menu bar and select Layout → Insert → Text Box.



Position the cursor on the correlation panel where you would like the top-left corner of the text box
to appear (it can be moved later).



Click the left mouse button.



The following dialog box opens:
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Enter the required text.



Select the font, font size, font style, and colour: these will apply to all the text in the box (if you need
more variety, use the Rich Text Box).



On the Colors and Lines tab you can:


select a colour fill for the text box, and



change the style of the line around the box (use white if you don’t want any line).



On the Position tab, you can specify the exact position of the text box.



Click OK when you have finished:

To move the text box, position the cursor over the text box, hold down the left button, and drag the box
to the required position.
To modify the text or any other feature of the text box, double-click over it to re-open the Text Box
Properties dialog box.
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9.11 Adding a Rich Text Box
To create a Rich Text Box:


Set up your text, including formatting, in a word processor.



Save your text as a Rich Text (*.rtf) file.



Create a Rich Text Box EITHER by clicking on the RTF icon on the Drawing toolbar, OR go to the main
menu bar and select Layout → Insert → Rich Text Box.



Position the cursor on the correlation panel where you would like the top-left corner of the text box
to appear (it can be moved later).



Double-click on the Rich Text Box to open the Properties dialog.



On the Text tab, click on the Import button and navigate to the *.rtf file.



Click Open to import the contents of the file.



Use the Colors and Lines tab to change the color fill and the style of the line bounding the box.



The position of the box can either be specified on the Position tab, or it can be moved using the
mouse.



The size of the box can be adjusted by clicking and dragging on its side and corner handles.

Note that you cannot modify the contents of a Rich Text Box within CycloLog: if textual changes are
required, make these changes to the *.rtf file in the word processor, then re-import it.

9.12 Adding a graphic to a correlation panel
Graphics objects can also be added to a correlation panel:


EITHER click the Image icon on the Drawing Toolbar, OR go to the main menu bar and select Layout
→ Insert → Image.



Click once over the correlation panel to indicate the location of the top left corner of the image.



In the dialog box that opens, navigate to the image file to be added.



Click Open.



The image can be moved and resized interactively in the correlation panel.



Right-click over the image to access its Properties dialog, in which you can specify the colour and
thickness of the line bounding the image.
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9.13 Printing and exporting a correlation panel
Correlation panels can be either printed directly from CycloLog, or exported as graphics files for use in
another application.

To prepare a correlation panel for printing:


To check the overall size of the panel, go to the main menu bar and select Output → Chart size. Write
down the size values in mm.



Use Page Setup and Print Setup (from the File menu) in the usual way, to set paper size, orientation
and margins, and to select a printer.



Use Print Preview to check the layout.

To export a correlation panel:


Go to the main menu bar and select Output.



Select the required graphics format (Bitmap, GIF, JPG, PNG, or TIFF).



Navigate to the required folder, and give the file a name.



Click Save.

You can also export the Correlation Panel as a PDF file (for details refer to the Help manual in CycloLog).
To do so:


Check the size of the correlation panel. Go to the menu bar and select Output → Chart Size. Write
down the size values in mm.



Go to File → Print Setup. Select the pdf print option (you will have to have a PDF driver installed on
your machine).



In Print Setup select the custom page size and use the size dimensions you wrote down above.



Set the resolution quality. Usually, 300 dpi is sufficient.



In File → Page Setup, you may add 2 or 3 mm’s to the page margins.



Check the customized dimensions with File → Print Preview or Print Preview from the Standard
toolbar.



If necessary, adjust the size and margins as described here above.



Print the PDF.
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Part 10 - Exporting data from CycloLog
10.1 Exporting data from CycloLog
In addition to a comprehensive range of possibilities for exporting data and graphics, CycloLog comprises
additional export function for reservoirs that enables direct communication with other platforms. The
exported files, however, can also be imported into other platforms. Some export options have been
mentioned elsewhere in the CycloLog Tutorial: here the most important functions are brought together
for the convenience of the user.
In the table below, an overview is given of the different data export options for wells, breaks and reservoirs
in CycloLog. The function of each export option and the reference to the Tutorial in which they are
discussed are also indicated.

Data Type

Wells

Export Option

Function

Tutorial
Base Module

File → Export → LAS File

Exports (selected) logs per well

This part 10.2

File → Export → General ASCII

Exports (selected) logs per well

This part 10.2

File → Export → CycloLog File

Exports (selected) logs per selected
well

This part 10.2

File → Export → Batch Export LAS

Exports (selected) logs for selected
wells

This part10.2

Edit → Edit Breaks: Break Manager

Per well, exports (selected) breaks
from a selected break set

Part 5.8 and this
part 10.3

Edit → Set Manager…

For selected wells, exports (selected)
breaks from selected break sets

Part 8.8

Edit → Edit Reservoirs: Reservoir
Manager

Per well, exports (selected)
reservoirs from a selected reservoir
set

Part 6.8 and this
part 10.4

Edit → Set Manager…

For selected wells, exports (selected)
reservoirs from selected reservoir
sets

Part 8.8

Breaks

Reservoirs
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10.2 Exporting wells
Wells can be exported from CycloLog as (1) a CycloLog file, (2) a LAS file, or (3) an ASCII (text) file.

10.2.1 Exporting wells as CycloLog files
Given a CycloLog project file with a number of wells in it, you may wish to export a single well as a separate
CycloLog file. To do this:


Go to the main menu bar and select File → Export → CycloLog File.



The following dialog box opens:
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Check the well(s) that you wish to export.



Check the Include composite charts box if you want any composite charts to be included in the
export.



Click OK.



In the Save As dialog box, name the new *.clg file and navigate to the folder you want to save it in.



Click Save.



CycloLog creates the new *.clg file.

10.2.2 Exporting wells as LAS files
It is also possible to export wells from CycloLog as standard LAS files: this can be useful for exporting (for
example) INPEFA curves in a form that can be easily loaded into another application.
To export a well to LAS:


Go to the main menu bar and select File → Export → LAS File. The following dialog box opens:
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In the LAS File Export Wizard:


Select the well for export from the Well drop-down list.



Specify the Depth Interval for export (the default is the full depth interval in the current CycloLog
project).



Under Select logs, check the logs to be exported (or, use Select All).



Click OK.



In the Save As box, specify the file name and folder.



Click Save.

10.2.3 Batch export of LAS files
From a CycloLog project file with more than one well, you can export several (or all) wells to LAS files at
the same time.


Go to the main menu bar and select File → Export → Batch Export LAS. The following dialog box
opens:



Either use the Select All button to select all the wells, or check the boxes in the left-hand (Export)
column for a selection of wells.



In the LAS File column, CycloLog suggests a filename for each LAS file to be created: to change any of
these, click over the file name and make your changes.
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By default, CycloLog will export the whole depth interval, but you can select part of the interval by
changing the depths in the Top and Bottom columns.



By default, CycloLog will export all of the logs for each well: the names of the first few logs will appear
in the Curve list column. To change your selection of logs, click in the curve list and then on the button
with three dots at the right hand end of the Curve list column. This will open the full list of logs:



Uncheck the logs that you that you do not wish to export (or, Select None, then check those that you
wish to export) and click OK.



Back in the Batch Export LAS dialog box, click on the Export button.



In the next dialog box, navigate to the folder into which the LAS files are to be saved (click on Make
New Folder button for a new folder).



Click OK to export the selected wells and logs to the new files.
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10.2.4 Exporting wells as ASCII files
It is also possible to export wells from CycloLog as a simple ASCII file. This may be your preferred route if
you wish to load the log data (including logs such as INPEFA curves that you may have generated in
CycloLog) into a spreadsheet or other application.

To export a well to ASCII:


Go to the main menu bar and select File → Export → General ASCII. The following dialog box opens:

PanTerra – ENRES Technical Alliance ● CycloLog Version 2019 ● Base Module ● Page 123



The General ASCII File Export dialog box has two tabs:


The Logs tab, which is identical to the dialog box for LAS export (see also above).



The Options tab.



On the Logs tab, specify the well, the depth interval, and the logs to be exported.



Go to the Options tab if you wish to include a text comment in the exported file, and/or to include
the names of the logs in the file.



Check the Include comment box and type a comment.



Check the Include log name box, if you want the names of the logs to be included in the file.



Click OK and specify the file name and folder in the Save As dialog: by default, the file will be saved
as *.asc; change this (e.g. to *.txt) if you wish.
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If you have opted to include a comment and the log names (as in the illustrated dialog box above), the
start of the new ASCII file will look like this:
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10.3 Exporting breaks
A set of stratigraphic ‘breaks’ is often the most important result from a study using CycloLog. Therefore,
it is important to be able to export the break data.
To export a set of breaks from a single well (see also part 5):


Open the Break Manager. This can be done in several ways:


From the main menu, select: Edit → Edit Breaks.



From the Edit Breaks icon on the Break Bar toolbar.



From the right-click menu over any open Lag Data pane.



From the right-click menu over a composite well chart.



Select the break set for export by clicking once on it in the Break Set list.



Click Export.



Select either File (to export to a file), or Clipboard (to transfer the data to another application such
as a spreadsheet).



If you select File, note that two formats are available:


Break File (*.brk), in which all of the break properties (depth, name, line style, comments, etc.) are
preserved. This file can only be read by CycloLog.



Tabular File (*.asc), in which only the break depth and break name are preserved.

Note: To export a batch of wells and their break sets and breaks, use the Set Manager see part 8.8.
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10.4 Exporting reservoir data
Like sets of Breaks, Reservoirs can be exported from a CycloLog project to an ASCII file, either for use in
another application, or for importing to another CycloLog project.
To export a set of reservoirs (see also part 6):


Open the Reservoir Manager. This can be done in several ways:


From the main menu, select: Edit → Edit Reservoirs.



From the Edit Reservoirs icon on the Reservoir Bar toolbar.



From the right-click menu over any open Lag Data pane.



From the right-click menu over a composite well chart.



Select the Reservoir set to be exported.



Uncheck any of the reservoirs that are not to be included in the export.



Click Export.



Select Clipboard (for immediate use in another application) or File (for export to a file).



If you selected File, browse to the appropriate folder, and give the file a name.



The file will be saved as a simple table with only top depth, bottom depth, and name (*.asc file). Select
from the Save as type list in the Save As dialog.

Note: To export a batch of wells and their break sets and breaks, use the Set Manager see part 8.8.
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10.5 Exporting graphics
Several kinds of CycloLog graphics can be exported, including:


Individual logs.



Composite well charts.



Correlation panels.

To export an individual log as a graphic file:


Open the log data pane (double-click its name in the workspace).



Make sure the log you want is active, by clicking once over its display (this important if more than one
log is displayed).



Click on the Output menu at the top of the screen.



From the list of available graphics formats, select one.



In the Image Width dialog, specify the width of the log column in the output file (default width is 5
cm). (For JPG output, you may also specify the quality of the output, on a scale from 0 – 100; the
default value is 80).



Click OK.



In the Save As dialog, specify the name of the file and the folder to which it is to be saved.



Click Save.



The file is saved and may be imported into other applications.
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To export a composite well chart:
A composite well chart can be directly printed from CycloLog, or exported as a graphics file.


Open the composite chart, or (if several data panes are open), click on the chart’s display pane to
make it the active pane.



To print, use File → Print Setup and File → Page Setup to set the appropriate page and print
parameters, then select File → Print (see for more details in part 4).



To export a composite chart as a graphics file, go to the Output menu, and select from the available
formats: Bitmap, GIF, JPG, PNG or TIFF.



You will be prompted for a file name and folder.



Click Save.

To export a Correlation Panel:
A correlation panel can be either directly printed from CycloLog, or exported as a graphics file.


Open the correlation panel, or (if several data panes are open), click on the chart’s display pane to
make it the active pane.



Check the overall size of the panel, go to the Output menu and select Chart Size (see for more details
in part 4).



Use Page Setup and Print Setup (from the File menu) in the usual way, to set paper size, orientation
and margins, and to select a printer.



Use Print Preview to check the layout.



Make any necessary changes then click Print.



To export a correlation panel as a graphics file, go to the Output menu, and select from the available
formats: Bitmap, GIF, JPG, PNG or TIFF.



You will be prompted for a file name and folder.



Click Save.
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